
Adobe Fireworks CS6 Project 1 guide
How to create a wireframe
A wireframe is a visual guide representing the basic elements of a website. Wireframes are used to describe the 
conceptual structure or information architecture of a website or application. A well-designed wireframe includes 
three key elements: interface design, navigation system, and main content areas (Figure 1). The functional 
relationships between these element are highlighted, where detailed graphics, typographic style, and colors are 
typically not emphasized. 

Fireworks is an ideal tool to mock up wireframes. Use the following guidelines to help you create a wireframe of your 
widget or website.

Figure 1 Wireframe proposal

Wireframing workflow
This worklow outlines the general steps for developing a wireframe from scratch. The result is to a fully-functional 
interactive prototype.

1. Create pen-and-ink draft 

Using pen and paper, sketch a home page or home screen. Include all major layout design elements you want to share 
across multiple pages or screens such as navigation, content areas, titles, and logos. Consider these questions:

• Graphics What graphics will you include? Where will you place the graphics on the page or screen?

• Text What text will you include? Where will you place text on the page or screen?

• Navigation According to your flowchart, the home page or screen directly links to what pages or screens 
(what are the menu items)? Where will you place these links on your home page or screen?

2. Scan and import your draft

Use a scanner to make a digital copy of your draft wireframe, import it into Fireworks.

3. Lay out common design elements

With the sketched draft for reference, use basic drawing tools and guides in Fireworks to block out the main design 
elements in the wireframe.
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4. Create multiple wireframe pages or screens

In the Pages panel, create the desired number of pages or screens for your initial design. As the design evolves, you 
can add or subtract pages or screens as needed.

5. Add unique elements to individual pages or screens

On each page, add unique design, navigation, or form elements. In the Common Library panel, you can find many 
buttons, text boxes, and pop-up menus that speed up the design process.

6. Simulate user navigation with links

Use web objects such as slices, hotspots, or navigation buttons to link the various pages or screens of your prototype.

7. Export the finished, interactive wireframe

Fireworks offers multiple output formats for your prototype, all of which retain hypertext links for navigation within 
the prototype.

Creating a wireframe with Adobe Fireworks CS6
Use Fireworks to create a basic two-page interactive wireframe document. 

Workflow steps 1 to 3

In this section, you  sketch out your wireframe, scan and import it into Fireworks, and lay out comon design elements. 

To create a wireframe from a sketch:

1. Using pen and paper, sketch your wireframe. Include all 
major components, such as navigation, content areas, 
titles, and logos.

2. Scan the sketch into your computer. 

3. Start Fireworks and create a new document 1024 pixels 
wide and 700 pixels high. 

Note: These dimensions are those of a typical web page. 
The dimensions may differ if you're designing a widget.

4. Open the Layers panel, and create or rename two layers: 

• Wireframe

• Wireframe Sketch

Make sure the Wireframe Sketch layer is below the 
Wireframe layer (Figure 2).

5. With the Wireframe Sketch layer selected, choose File > 
Import.

The Import dialog box opens.

6. Navigate to the file you scanned in step 2, and click 
Import (Windows) or Open (Mac OS).

7. Click in the upper-left corner of the canvas to place the 
imported sketch at that location. 

You need to scale the sketch to fit the canvas. Click the 
imported sketch to select it.

Figure 2 Wireframe and Wireframe Sketch layers 
added to the Layers panel
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8. The sketch may extend beyond the edges, or not fully fit  
inside the canvas. 

9. In the Properties panel, select the Constrain Proportions 
option (Figure 3).

10. In the Width Pixel Dimension text box, type 1024, and 
confirm the X and Y coordinates are set to 0.

11. Press Tab.

The image resizes to fit the canvas width.

12. In the Layers panel, lock the Wireframe Sketch layer.

This sketch layer will be the background reference to lay 
out the wireframe elements.

13. Select the Wireframe layer.

14. Make sure rulers and guides are visible. If not, select 
View > Rulers and View > Guides > Show Guides.

15. To create a horizontal or vertical guide, click then drag 
from the corresponding ruler respectively to the edges of 
the logo area, the main content area, and the first 
navigation button (Figure 4).

Note: Guide color can be changed to be more visible 
against different backgrounds. To change the guide color, 
select Edit > Preferences (Windows) or Fireworks > 
Preferences (Mac OS)  and select the Guides And Grids 
category.

16. Select View > Guides > Lock Guides.

Locking the guides prevents you from moving them 
unintentionally.

17. Select View > Guides > Snap To Guides.

The snapping feature enables you to align objects 
precisely with the guides as long as you get close. You 
can control how close you have to get (Snap Distance) in 
Guides And Grids. preferences.

18. Select the Rectangle tool from the Tools panel.

19. In the Properties panel, make the following changes 
(Figure 5):

a. Select None from the Fill pop-up menu.

b. Select Basic > Soft Line from the Stroke pop-up 
menu.

c. Set Stroke color to dark grey.

d. Set Stroke width to 10 pixels.

20. Using the guides, draw a rectangle around the main 
content area, and logo area of the sketch (Figure 6).

As you draw, the rectangles snap to the guides.

Figure 3 Properties panel

Figure 4 Imported sketch with guides added

Figure 5 Rectangle Properties panel

Figure 6 Rectangles drawn around page elenents

Width Pixel Dimension text box

Constrain 
Proportions 
option

X and Y Positions

No Fill option
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21. Select the Rounded Rectangle tool from the Tools panel.

22. Draw a rounded rectangle around the first navigation 
button of your wireframe (Figure 7).

23. Use the Pointer tool to select the rounded rectangle. Alt-
drag (Windows) or Option-drag (Mac) to the left to create 
a copy of the rectangle, and place it over the second 
navigation button in your wireframe.

Note: You may see a Fireworks warning box telling you 
that editing sub-elements of an Auto Shape may cause it 
to behave unpredictably. Select the Don’t Show Again 
option and click OK to dismiss.

24. Select Edit > Repeat Duplicate. 

This action creates a second copy with the same gap 
space between copies.

25. Continue repeating duplicates until you have created as 
many navigation buttons as needed for your wireframe 
sketch (Figure 8).

Now it's time to add the text labels. 

26. Choose Select > Deselect.

27. From the Tools panel, select the Text tool.

28. In the Properties panel, click the Fill color box and 
choose a dark color. Set the justification to Center 
Alignment and the Text Size to 30.

29. Click once in the logo rectangle and enter the text Logo.

30. Make sure Smart Guides are visible and active. If not, 
select View > Smart Guides, and then select Show Smart 
Guides and Snap To Smart Guides.

31. Drag the text block to center it in the rectangle, and 
continue adding text labels for the navigation buttons and 
main content area.

The Smart Guides help you to create, align, edit, and 
transform objects relative to other objects.

32. Choose View > Guides > Show Guides to hide guides.

33. Once you are satisfied with the position of the text and 
rectangle elements, click the eye icon next to the 
Wireframe Sketch layer to turn off visibility of the 
background layer. 

With the sketch layer turned off, your image should look 
similar to Figure 9.

34. Select File > Save As and save the file as a PNG.

Figure 7 Rounded rectangle drawn around 
navigation button

Figure 8 Three copies of the rounded buttons 

Figure 9 Completed wireframe sketch
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Workflow steps 4 and 5

Now that you have created the very basic wireframe of the page or screen layout, the next step is to create a few pages 
or screens showing various content. Fireworks CS6 enables you to create as many pages or screens as needed, with 
shared and unique items on each page.

To create multiple wireframe pages or screens:

1. Open the Pages panel (Window > Pages) if it isn't already 
displayed on the right side of the workspace (Figure 10).

2. Right-click (Windows) or Control-click (Mac OS) the 
current page in the Pages panel, and choose Set As 
Master Page from the context menu.

3. At the bottom of the Pages panel, click the Add Page 
button twice to add two blank pages.  

The new pages display the master page in the 
background.

4. Double-click the new page names to rename them, 
respectively, as Home and Shop (or whatever name you 
are using for the  second page of your wireframe). 

5. Navigate to the Home page by selecting it in the Pages 
panel (Figure 11).

6. Use the Text tool to add a page title at the top of the main 
content area.

7. Navigate to the Shop page by selecting it in the Pages 
panel, and use the Text tool to add a page title at the top 
of the main content area in the same way as on the Home 
page.

8. Select the Rectangle tool from the Tools panel.

9. In the Properties panel, select neutral colors for Fill and 
Stroke.

10. Draw a rectangle in the main content area of the second 
page, beside the page title. This rectangle stands in as a 
placeholder for a Shop page image or text page content 
(Figure 12).

11. Select File > Save.

Figure 10 Pages panel

Figure 11 Pages panel, Home page selected

Figure 12 Adding page-level placeholder content

Pages options
menu

Add Page 
button
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Workflow step 6

In this section, you use hotspot web objects to create navigation buttons or links between the two pages of your 
prototype.

To add navigation to a wireframe:

1. Navigate to the master page by selecting it in the Pages 
panel.

2. From the Tools panel, select the Rectangle Hotspot tool 
(Figure 13).

3. Draw a hotspot over the Logo rectangle area. 

4. Draw another hotspot over the first rounded rectangle 
area (Figure 14).

5. Select the first hotspot with the Pointer tool.

6. In the Properties panel, set Link to Home.htm 
(Figure 15).

7. Select the second hotspot and set Link in the Properties 
panel to Shop.htm (or to whatever you named the second 
page).

Because the hotspots are located on the master page, 
every page will be linked to the others when export the 
Fireworks file to an interactive PDF.

8. Select File > Save.

Figure 13 Tools panel

Figure 14 Drawing hotspots

Figure 15 Properties panel

Workflow step 7

Export an interactive prototype of your wireframe to both PDF and functional HTML (Figure 16). 

An interactive PDF is ideal for facilitating the client review process because the client can click through the flow of 
the site or widget, and make comments as needed by using the tools available in Adobe Acrobat. 

Fireworks generates pure HTML that can be read by most web browsers and HTML editors. You can then preview 
your wireframe interactivity and edit these files in Dreamweaver.

Figure 16 Export wireframes from Fireworks

Rectangle Hotspot tool

Link menu
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To export an interactive PDF:

1. Choose File > Export.

The Export dialog box opens (Figure 17).

2. From the Export pop-up menu, choose Adobe PDF. 

3. Confirm that the option View PDF After Export is 
selected.

4. Specify a filename and location, and then click Save 
(Windows) or Export (Mac OS).

The wireframe is exported to PDF and opens in Acrobat.

5. Test that the wireframe links work as expected 
(Figure 18).  

Figure 17 Export dialog box

Figure 18 Testing links in Acrobat PDF

To export to HTML and images:

1. Choose File > Export.

The Export dialog box opens.

2. Navigate to a folder on your hard drive in which to 
export.

3. From the Export pop-up menu, choose HTML And 
Images.

4. Select All Pages from the Pages menu.

5. To store images in a separate folder, select the option Put 
Images In Subfolder. You can select a specific folder or 
use the Fireworks default Images subfolder.

View PDF After Export option
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6. Specify a filename, and then click Save  (Windows) or 
Export (Mac OS).

After export, you'll see the files Fireworks exported on 
your hard drive. Images and an HTML file are generated 
in the location you specified in the Export dialog box.

7. Navigate to the location of the saved file, open 
Home.htm in a browser, and test whether the wireframe 
links work as expected (Figure 19).

Figure 19 Testing HTMLin a browser
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